1. The second prompt is revealed! (Q2 2018)

    "Breaking into Snape's office in the middle of the night was a risky move at the best of times..."

    Deadline is June 18th, also known as the 22nd Anniversary of a seriously sad day—a tremendously black day for anyone.

    As with before you can check out the new thread discussing scoring, rules, and other such matters in the in the Story Competitions forum.

    Dismiss Notice

Resolved Minor UI bug: "Go to First Unread" button not displaying correctly

Discussion in 'DLP Feedback and Improvement' started by moonpotato, Jun 2, 2018.

  1. moonpotato

    moonpotato First Year

    Joined:
    Jun 1, 2015
    Messages:
    35
    Location:
    Bestern Australia
    On some threads, the "Go To First Unread" button appears too thin, causing the text to spill off the right-hand side of the button. I haven't checked thoroughly but it seems like this happens only for threads that don't have multiple pages of posts.

    I assume this is some minor bug in the site's CSS, though once again I haven't really looked much into it yet. Attached is a combination of screenshots which demonstrates the issue, the same on many pages, in comparison to examples where it looks fine. It is very minor.

    DLP Issue.png
     
  2. Zombie

    Zombie John Waynes Teeth Prestige DLP Supporter

    Joined:
    Apr 28, 2007
    Messages:
    1,297
    Location:
    Within the Garden of Nurgle.
    High Score:
    2,094
    upload_2018-6-8_10-52-46.png
    This is what I'm seeing everywhere.

    Can you link me the thread in which the first image occurred? I cannot seem to find one that appears that way at all. I almost thought it had been resolved.
     
  3. Sataniel

    Sataniel Groundskeeper

    Joined:
    Jan 24, 2016
    Messages:
    315
    High Score:
    0
    I would assume it's theme's fault. I've seen it too on Incog.
     
  4. Zombie

    Zombie John Waynes Teeth Prestige DLP Supporter

    Joined:
    Apr 28, 2007
    Messages:
    1,297
    Location:
    Within the Garden of Nurgle.
    High Score:
    2,094
    Well, anyways:

    Add this to stylish until it can be added to the final code base.

    Lemme know if it doesn't work.

    Code:
    .unreadLink {
    height: 20px;
    width: auto ;
    }
     
  5. lopeck

    lopeck Third Year

    Joined:
    Oct 22, 2013
    Messages:
    99
    Location:
    Germany
    This was brought up a while agohere.

    It still happens to me on occasion. And in this very thread.
     
  6. Zombie

    Zombie John Waynes Teeth Prestige DLP Supporter

    Joined:
    Apr 28, 2007
    Messages:
    1,297
    Location:
    Within the Garden of Nurgle.
    High Score:
    2,094
    Did you try they stylish code Because it resolved the problem for me anywhere it was showing before. Just wanted to see if more needed to be done to fix it.
     
  7. moonpotato

    moonpotato First Year

    Joined:
    Jun 1, 2015
    Messages:
    35
    Location:
    Bestern Australia
    It was happening on this thread (until I refreshed the page and the button disappeared).

    Yes that CSS rule clears things up fine. Though I'd suggest using 18px for the height instead because that's how it appears on the other pages (and that matches up with the heights of the page number buttons, too).
     
  8. lopeck

    lopeck Third Year

    Joined:
    Oct 22, 2013
    Messages:
    99
    Location:
    Germany
    It only happens sporadically. So I couldn't say for sure if the stylish code worked immediately. But there haven't been any more instances since yesterday.
     
  9. KGB

    KGB Order Member

    Joined:
    Jan 18, 2011
    Messages:
    852
    It appears to happen only when there is a single page of content and there are new posts in it.

    When there are more than one page it displays correctly.

    Edit: This is using Incog style.
     
  10. moonpotato

    moonpotato First Year

    Joined:
    Jun 1, 2015
    Messages:
    35
    Location:
    Bestern Australia
    That is consistent with what I've seen as well. I'm using WIP theme.
     
  11. lopeck

    lopeck Third Year

    Joined:
    Oct 22, 2013
    Messages:
    99
    Location:
    Germany
    It's still popping up with the stylish code.
    Unred Bug.png
     
  12. moonpotato

    moonpotato First Year

    Joined:
    Jun 1, 2015
    Messages:
    35
    Location:
    Bestern Australia
    Try replacing
    Code:
    .unreadLink
    with
    Code:
    .PageNav a.unreadLink
    in the Stylish code. It looks like the rule gets overridden by another rule otherwise.
     
  13. Lord Ravenclaw

    Lord Ravenclaw System God Admin

    Joined:
    Apr 2, 2005
    Messages:
    4,253
    Location:
    Denver, CO
    I pushed a fix to the underlying CSS. Let me know if you still see it.
     
  14. moonpotato

    moonpotato First Year

    Joined:
    Jun 1, 2015
    Messages:
    35
    Location:
    Bestern Australia
    Looks fine to me now.
     
Loading...