1. Hi there, Guest

    Only registered users can really experience what DLP has to offer. Many forums are only accessible if you have an account. Why don't you register?
    Dismiss Notice

Not a Problem Buggy Time

Discussion in 'DLP Feedback and Improvement' started by Oment, Oct 29, 2017.

  1. Oment

    Oment The Betrayer

    Joined:
    Apr 11, 2011
    Messages:
    1,977
    So, most of Europe switched DST back last night, and that has led to a few interesting things on the forum index. To wit:

    [​IMG]

    So, as of right now, it's still Sunday over here, and Oz's post was made about six and a half hours ago - it's his post-marathon reporting in. That's not yesterday - yesterday is still Saturday to me, though Saturday isn't yesterday for the forum (see Invictus's post in Politics.)

    This is the same in the forums itself, by the way. However, hovering over a post to find out the time it was made reveals the correct time, as seen by Gengar's post here:

    [​IMG]

    I'm using the Central European Time setting in Preferences, and the skin is the WIP skin, though a quick check on Light Lord Potter revealed that it was the same there. It's probably minor, but it's the kind of thing that bugs me.
     
  2. Lord Ravenclaw

    Lord Ravenclaw DLP Overlord Admin

    Joined:
    Apr 2, 2005
    Messages:
    4,277
    Location:
    Denver, CO
    Some questions to start off with:

    Does this occur consistently or just since the European DST switch? Does it happen when you've left the forum open for a while, or after a fresh pageload? Which browser? Is your computer's date set correctly?

    Either way, I'll take a look. This isn't something I've written so I'd be more inclined to forward the bug on to XenForo to fix for everyone if I can figure out the specific circumstances which bring it about, since at a glance the code is pretty clear on when to display the "yesterday" message: if the time difference between you and the post is >= 86400 seconds (number of seconds in a day), but there's always potential issues with browser time.
     
  3. Oment

    Oment The Betrayer

    Joined:
    Apr 11, 2011
    Messages:
    1,977
    Firefox 56 or whatever the hell the latest was on Sunday, computer's date is set correctly to the best of my knowledge - it autosyncs once a week). Fresh-ish pageload (I'd visited DLP earlier in the browser session, but I opened it in a new tab), first noticed it after EU DST switch -- your comment about the 86400 seconds in a day might actually be the thing that set it off. (I haven't been around in the relevant hour since Sunday.) Might just be some weird DST shenanigan only for that day.

    Will report in tomorrow.
    --- Post automerged ---
    Couldn't find post to confirm testing with, using this as anchor for tomorrow.
    --- Post automerged ---
    Yep, it was the 86400 seconds clause fucking it up. A 'problem', if you can call it that, for only a few days a year. (I.e. the DST days.)